解决composer内存超出allowedmemorysizeof

 我们在使用 composer update xxx 更新 php 包时或者使用 composer require xxx 下载 php 包时,当composer包过大或者电脑内存太小的时候会就出现内存超出,内存溢出异常 Allowed memory size of xxx 如下PHP Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 4096 bytes) in phar:///usr/bin/composer/src/Composer/DependencyResolver/Solver.php on line 223 Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 4096 bytes) in phar:///usr/bin/composer/src/Composer/DependencyResolver/Solver.php on line ...

PHP,Linux,解决方案 2021-12-01 AM 824次 0条

go引入使用包异常cannot resolve symbol 'xxx'

 本文主要解决 golang 引入使用 gin包 的时候异常 cannot resolve symbol 'xxx' 这个问题一般比较 熟悉go语言 的同学一眼就知道怎么解决了,本文主要记录下以供其他新同学 排查问题 使用。go出现 cannot resolve symbol 异常原因 go.mod 文件没有 require 包,或者没有初始化 go.mod 解决 cannot resolve symbol 'xxx' 异常go mod init gin go mod edit -require github.com/gin-gonic/gin@latest 使用 go.mod 注意事项go使用go mod加速依赖管理 关于 go引入使用包异常cannot resolve symbol 'xxx' 通过以上方法已经完美解决了。

Golang,解决方案 2021-09-28 PM 1119次 0条

composer常用命令

 本文主要记录整理经常使用到的 composer 命令,以便后期查看composer 查看版本composer --versioncomposer 更新升级到指定版本composer self-update --2 #或 composer self-update --1composer 版本回退命令composer self-update --rollbackcomposer 快速安装更新版本 使用一下命令会自动创建 composer.jsoncomposer require 库名 [版本号]composer 安装时展示详情composer require 库名 [版本号] -vvvcomposer 初始化开发新包composer initcomposer 手动新增配置安装 手动新增 composer.json 文件,然后执行安装composer installcomposer 移除第三方包composer remove xxxx/xxxxcomposer 更新所有依赖 根据 composer.json 中的配置更新所有依赖包composer updatecomposer 更新指...

PHP,其他 2021-09-28 PM 421次 0条

go使用go mod加速依赖管理

 我们使用 go mod 可以很方便的管理使用 go 第三库,但是国内引用第三方库时候因为国内网络环境问题会非常慢,甚至可以说经常获取不到,今天我们就讲一下怎么加速 go mod 包下载。 go mod 国内代理提供商源站地址备注七牛云https://goproxy.cn/中国最可靠的 Go 模块代理 (推荐)goproxy.iohttps://goproxy.io/一个全球代理为 Go 模块而生 (推荐)阿里云http://mirrors.aliyun.com/goproxy/阿里云 go module公共代理仓库nexus社区https://gonexus.dev/为社区而制作怎么使用 go mod 国内代理go 1.13 及以上,配置go mod 国内代理(推荐)go env -w GO111MODULE=on go env -w GOPROXY=https://goproxy.cn,directmac 或 linux 配置go mod 国内代理export GO111MODULE=on export GOPROXY=https://goproxy.cn # 还可以设置不...

Golang,解决方案 2021-09-24 PM 1072次 0条

composer升级到2.x版本和降级

 经常使用php开发程序的同学应该经常接触并使用过 composer php包管理器,composer 2.0版本已经在 2020年1月份 下旬发布正式发布了,这就意味着composer 1.x版本即将退出 composer 的舞台,但是有很多已经在使用的包依旧是composer 1.x版本,以至于我们在开发过程中需要不断的在两个版本之间切换,下面我们讲一下怎么使用composer升级到的 2.x版本 和回退降级到 1.x版本查看当前 composer 版本 首先我们通过命令行查看当前 composer 版本,我们在命令行输入一下 composer 命令 composer --version 可以看到我的当前版本为 composer 1.10 版本升级 composer 版本 接着我们通过 self-update 升级 composer 版本composer self-update # 或者 composer self-update 2 # 或者 composer self-update --2 可以看到我们已经成功将 composer 升级到 2.1.8 最新版本了compos...

PHP,软件工具,Linux,解决方案 2021-09-18 AM 1984次 0条